WordPress: dernière version de jQuery

Par défaut, WordPress propose une version de jQuery qui n’est pas forcément la plus à jour. On peut avoir besoin de la remplacer par une version plus récente, la raison la plus simple étant qu’une version plus récente peut avoir corrigé le bug de jQuery qui empêche une page de fonctionner.

Voici le code php pour le faire:

if( ! is_admin() ){
 wp_deregister_script( 'jquery' );
 wp_register_script( 'jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js', false, '', false);
 }

Dans l’url, le fait de mettre jquery/1/ suppose qu’on veut la dernière mouture de jQuery version 1.
Si on veut la dernière livraison de jQuery 2, remplacer par jquery/2/
tiré de: http://code.garyjones.co.uk/use-latest-jquery-wordpress

March 12, 2014
single-default.php

Comments are closed.

footer.php